const regex = /^(?:[0-9]{2}){1,10}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[0-9]{2}){1,10}$', 'gm')
const str = `2
22
222
2222
22222
222222
2222222
22222222
22222222222222222222
222222222222222222222
2222222222222222222222`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}