$re = '/^(?:[0-9]{2}){1,10}$/m';
$str = '2
22
222
2222
22222
222222
2222222
22222222
22222222222222222222
222222222222222222222
2222222222222222222222';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);