import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[0-9]{2}){1,10}$";
final String string = "2\n"
+ "22\n"
+ "222\n"
+ "2222\n"
+ "22222\n"
+ "222222\n"
+ "2222222\n"
+ "22222222\n"
+ "22222222222222222222\n"
+ "222222222222222222222\n"
+ "2222222222222222222222";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}