#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https:\/\/www\.test\.com\/(us|eu|fr)\/(page[12])"
Local $sString = "https://www.test.com/us/page1 " & @CRLF & _
"https://www.test.com/us/page2 " & @CRLF & _
"https://www.test.com/eu/page1 " & @CRLF & _
"https://www.test.com/eu/page2 " & @CRLF & _
"https://www.test.com/fr/page1 " & @CRLF & _
"https://www.test.com/fr/page2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")