using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https:\/\/www\.test\.com\/(us|eu|fr)\/(page[12])";
string input = @"https://www.test.com/us/page1
https://www.test.com/us/page2
https://www.test.com/eu/page1
https://www.test.com/eu/page2
https://www.test.com/fr/page1
https://www.test.com/fr/page2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}