package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https:\/\/www\.test\.com\/(us|eu|fr)\/(page[12])`)
var str = `https://www.test.com/us/page1
https://www.test.com/us/page2
https://www.test.com/eu/page1
https://www.test.com/eu/page2
https://www.test.com/fr/page1
https://www.test.com/fr/page2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}