$re = '/https:\/\/www\.test\.com\/(us|eu|fr)\/(page[12])/m';
$str = 'https://www.test.com/us/page1
https://www.test.com/us/page2
https://www.test.com/eu/page1
https://www.test.com/eu/page2
https://www.test.com/fr/page1
https://www.test.com/fr/page2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);