use strict;
my $str = 'https://www.test.com/us/page1
https://www.test.com/us/page2
https://www.test.com/eu/page1
https://www.test.com/eu/page2
https://www.test.com/fr/page1
https://www.test.com/fr/page2';
my $regex = qr/https:\/\/www\.test\.com\/(us|eu|fr)\/(page[12])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}