using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i) \\b \\w*title=\"" \\w+ \\b \\w*\""";
string input = @"<doc id=\""15801890\"" url=\""https://en.wikipedia.org/wiki?curid=15801890\"" title=\""Zalm\""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}