$re = '/(?i) \\\\b \\\\w*title=\" \\\\w+ \\\\b \\\\w*\"/';
$str = '<doc id=\\"15801890\\" url=\\"https://en.wikipedia.org/wiki?curid=15801890\\" title=\\"Zalm\\"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);