import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i) \\\\b \\\\w*title=\\\" \\\\w+ \\\\b \\\\w*\\\"";
final String string = "<doc id=\\\"15801890\\\" url=\\\"https://en.wikipedia.org/wiki?curid=15801890\\\" title=\\\"Zalm\\\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}