// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i) \\b \\w*title=\" \\w+ \\b \\w*\""#).unwrap();
let string = "<doc id=\\\"15801890\\\" url=\\\"https://en.wikipedia.org/wiki?curid=15801890\\\" title=\\\"Zalm\\\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}