re = /(?i) \\b \\w*title=\" \\w+ \\b \\w*\"/
str = '<doc id=\\"15801890\\" url=\\"https://en.wikipedia.org/wiki?curid=15801890\\" title=\\"Zalm\\"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end