#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)(?&object) # Find the object" & @CRLF & _
"" & @CRLF & _
"####################" & @CRLF & _
"" & @CRLF & _
"(?(DEFINE)" & @CRLF & _
" " & @CRLF & _
" (?<name>" & @CRLF & _
" " \s* [^\s"]+ \s* " " & @CRLF & _
" )" & @CRLF & _
" " & @CRLF & _
" (?<value>" & @CRLF & _
" " & @CRLF & _
" (?>" & @CRLF & _
" (?:" & @CRLF & _
" (?&string) " & @CRLF & _
" | (?&number) " & @CRLF & _
" | (?&object) " & @CRLF & _
" | (?&array) " & @CRLF & _
" | (?&T_F_N) " & @CRLF & _
" " & @CRLF & _
" )" & @CRLF & _
" )" & @CRLF & _
" )" & @CRLF & _
" " & @CRLF & _
" (?<string>" & @CRLF & _
" "" & @CRLF & _
" [^"]* " & @CRLF & _
" "" & @CRLF & _
" )" & @CRLF & _
" (?<number>" & @CRLF & _
" \d+ " & @CRLF & _
" )" & @CRLF & _
" " & @CRLF & _
" (?<array>" & @CRLF & _
" \[ " & @CRLF & _
" (?:" & @CRLF & _
" \s* (?&value) " & @CRLF & _
" (?>" & @CRLF & _
" (?:" & @CRLF & _
" \s* , \s* " & @CRLF & _
" (?&value) " & @CRLF & _
" )*" & @CRLF & _
" )" & @CRLF & _
" )?" & @CRLF & _
" \s* \] " & @CRLF & _
" " & @CRLF & _
" )" & @CRLF & _
" (?<T_F_N>" & @CRLF & _
" true" & @CRLF & _
" | false" & @CRLF & _
" | null" & @CRLF & _
" )" & @CRLF & _
" (?<object>" & @CRLF & _
" {" & @CRLF & _
" (?:" & @CRLF & _
" \s* (?&name) \s* : \s* (?&value) " & @CRLF & _
" (?:" & @CRLF & _
" \s* , \s* (?&name) \s* :" & @CRLF & _
" \s* (?&value) " & @CRLF & _
" )*" & @CRLF & _
" \s* " & @CRLF & _
" )" & @CRLF & _
" }" & @CRLF & _
" )" & @CRLF & _
" " & @CRLF & _
")" & @CRLF & _
""
Local $sString = "{" & @CRLF & _
" "firstName": "Duke"," & @CRLF & _
" "lastName": "Java"," & @CRLF & _
" "age": 18," & @CRLF & _
" "streetAddress": "100 Internet Dr"," & @CRLF & _
" "city": "JavaTown"," & @CRLF & _
" "state": "JA"," & @CRLF & _
" "postalCode": "12345"," & @CRLF & _
" "phoneNumbers": [" & @CRLF & _
" { "Mobile": "111-111-1111" }," & @CRLF & _
" { "Home": "222-222-2222" }" & @CRLF & _
" ]" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")