// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?x)(?&object) # Find the object
####################
(?(DEFINE)
(?<name>
" \s* [^\s"]+ \s* "
)
(?<value>
(?>
(?:
(?&string)
| (?&number)
| (?&object)
| (?&array)
| (?&T_F_N)
)
)
)
(?<string>
"
[^"]*
"
)
(?<number>
\d+
)
(?<array>
\[
(?:
\s* (?&value)
(?>
(?:
\s* , \s*
(?&value)
)*
)
)?
\s* \]
)
(?<T_F_N>
true
| false
| null
)
(?<object>
{
(?:
\s* (?&name) \s* : \s* (?&value)
(?:
\s* , \s* (?&name) \s* :
\s* (?&value)
)*
\s*
)
}
)
)
"#).unwrap();
let string = "{
\"firstName\": \"Duke\",
\"lastName\": \"Java\",
\"age\": 18,
\"streetAddress\": \"100 Internet Dr\",
\"city\": \"JavaTown\",
\"state\": \"JA\",
\"postalCode\": \"12345\",
\"phoneNumbers\": [
{ \"Mobile\": \"111-111-1111\" },
{ \"Home\": \"222-222-2222\" }
]
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}