import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?&object) # Find the object\n\n"
+ "####################\n\n"
+ "(?(DEFINE)\n"
+ " \n"
+ " (?<name>\n"
+ " \" \\s* [^\\s\"]+ \\s* \" \n"
+ " )\n"
+ " \n"
+ " (?<value>\n"
+ " \n"
+ " (?>\n"
+ " (?:\n"
+ " (?&string) \n"
+ " | (?&number) \n"
+ " | (?&object) \n"
+ " | (?&array) \n"
+ " | (?&T_F_N) \n"
+ " \n"
+ " )\n"
+ " )\n"
+ " )\n"
+ " \n"
+ " (?<string>\n"
+ " \"\n"
+ " [^\"]* \n"
+ " \"\n"
+ " )\n"
+ " (?<number>\n"
+ " \\d+ \n"
+ " )\n"
+ " \n"
+ " (?<array>\n"
+ " \\[ \n"
+ " (?:\n"
+ " \\s* (?&value) \n"
+ " (?>\n"
+ " (?:\n"
+ " \\s* , \\s* \n"
+ " (?&value) \n"
+ " )*\n"
+ " )\n"
+ " )?\n"
+ " \\s* \\] \n"
+ " \n"
+ " )\n"
+ " (?<T_F_N>\n"
+ " true\n"
+ " | false\n"
+ " | null\n"
+ " )\n"
+ " (?<object>\n"
+ " \\{\n"
+ " (?:\n"
+ " \\s* (?&name) \\s* : \\s* (?&value) \n"
+ " (?:\n"
+ " \\s* , \\s* (?&name) \\s* :\n"
+ " \\s* (?&value) \n"
+ " )*\n"
+ " \\s* \n"
+ " )\n"
+ " \\}\n"
+ " )\n"
+ " \n"
+ ")\n";
final String string = "{\n"
+ " \"firstName\": \"Duke\",\n"
+ " \"lastName\": \"Java\",\n"
+ " \"age\": 18,\n"
+ " \"streetAddress\": \"100 Internet Dr\",\n"
+ " \"city\": \"JavaTown\",\n"
+ " \"state\": \"JA\",\n"
+ " \"postalCode\": \"12345\",\n"
+ " \"phoneNumbers\": [\n"
+ " { \"Mobile\": \"111-111-1111\" },\n"
+ " { \"Home\": \"222-222-2222\" }\n"
+ " ]\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}