import Foundation
let pattern = #####################"""
(?&object) # Find the object
####################
(?(DEFINE)
(?<name>
" \s* [^\s"]+ \s* "
)
(?<value>
(?>
(?:
(?&string)
| (?&number)
| (?&object)
| (?&array)
| (?&T_F_N)
)
)
)
(?<string>
"
[^"]*
"
)
(?<number>
\d+
)
(?<array>
\[
(?:
\s* (?&value)
(?>
(?:
\s* , \s*
(?&value)
)*
)
)?
\s* \]
)
(?<T_F_N>
true
| false
| null
)
(?<object>
{
(?:
\s* (?&name) \s* : \s* (?&value)
(?:
\s* , \s* (?&name) \s* :
\s* (?&value)
)*
\s*
)
}
)
)
"""#####################
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"""
{
"firstName": "Duke",
"lastName": "Java",
"age": 18,
"streetAddress": "100 Internet Dr",
"city": "JavaTown",
"state": "JA",
"postalCode": "12345",
"phoneNumbers": [
{ "Mobile": "111-111-1111" },
{ "Home": "222-222-2222" }
]
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)