using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?&object) # Find the object
####################
(?(DEFINE)
(?<name>
"" \s* [^\s""]+ \s* ""
)
(?<value>
(?>
(?:
(?&string)
| (?&number)
| (?&object)
| (?&array)
| (?&T_F_N)
)
)
)
(?<string>
""
[^""]*
""
)
(?<number>
\d+
)
(?<array>
\[
(?:
\s* (?&value)
(?>
(?:
\s* , \s*
(?&value)
)*
)
)?
\s* \]
)
(?<T_F_N>
true
| false
| null
)
(?<object>
{
(?:
\s* (?&name) \s* : \s* (?&value)
(?:
\s* , \s* (?&name) \s* :
\s* (?&value)
)*
\s*
)
}
)
)
";
string input = @"{
""firstName"": ""Duke"",
""lastName"": ""Java"",
""age"": 18,
""streetAddress"": ""100 Internet Dr"",
""city"": ""JavaTown"",
""state"": ""JA"",
""postalCode"": ""12345"",
""phoneNumbers"": [
{ ""Mobile"": ""111-111-1111"" },
{ ""Home"": ""222-222-2222"" }
]
}";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}