#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(\d+) # qty" & @CRLF & _
" \s+cases?\s+of\s+" & @CRLF & _
" (.+?) # product" & @CRLF & _
" \s+(\d{4}) # year" & @CRLF & _
" \s+at\s+\$([\d,]+\.\d{2}) # price" & @CRLF & _
" \s+in\s+(.+?)(?=\s+—\s+|$) # warehouse" & @CRLF & _
" (?:\s+—\s+(.+))? # remark"
Local $sString = " - 1 case of ProductA 2020 at $123,456.00 in Warehouse A" & @CRLF & _
" - 2 cases of ProductB 2025 at $123,456.00 in Warehouse B — optional remark" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")