$re = '/(\d+) # qty
\s+cases?\s+of\s+
(.+?) # product
\s+(\d{4}) # year
\s+at\s+\$([\d,]+\.\d{2}) # price
\s+in\s+(.+?)(?=\s+—\s+|$) # warehouse
(?:\s+—\s+(.+))? # remark/mx';
$str = ' - 1 case of ProductA 2020 at $123,456.00 in Warehouse A
- 2 cases of ProductB 2025 at $123,456.00 in Warehouse B — optional remark
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);