// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)(\d+) # qty
\s+cases?\s+of\s+
(.+?) # product
\s+(\d{4}) # year
\s+at\s+\$([\d,]+\.\d{2}) # price
\s+in\s+(.+?)(?=\s+—\s+|$) # warehouse
(?:\s+—\s+(.+))? # remark").unwrap();
let string = " - 1 case of ProductA 2020 at $123,456.00 in Warehouse A
- 2 cases of ProductB 2025 at $123,456.00 in Warehouse B — optional remark
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}