# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(\d+) # qty
\s+cases?\s+of\s+
(.+?) # product
\s+(\d{4}) # year
\s+at\s+\$([\d,]+\.\d{2}) # price
\s+in\s+(.+?)(?=\s+—\s+|$) # warehouse
(?:\s+—\s+(.+))? # remark
"""
test_str = (" - 1 case of ProductA 2020 at $123,456.00 in Warehouse A\n"
" - 2 cases of ProductB 2025 at $123,456.00 in Warehouse B — optional remark\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.