use strict;
my $str = ' - 1 case of ProductA 2020 at $123,456.00 in Warehouse A
- 2 cases of ProductB 2025 at $123,456.00 in Warehouse B — optional remark
';
my $regex = qr/(\d+) # qty
\s+cases?\s+of\s+
(.+?) # product
\s+(\d{4}) # year
\s+at\s+\$([\d,]+\.\d{2}) # price
\s+in\s+(.+?)(?=\s+—\s+|$) # warehouse
(?:\s+—\s+(.+))? # remark/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}