using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?:\/\/www?\.?linkedin\.com(\/voyager\/api\/voyagerSocialDashReactions)\?(threadUrn=(urn*.+)|(action=updateReaction)|(action=deleteReaction))";
string input = @"https://www.linkedin.com/voyager/api/voyagerSocialDashReactions?threadUrn=urn:li:activity:7033962785659105280";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}