re = /https?:\/\/www?\.?linkedin\.com(\/voyager\/api\/voyagerSocialDashReactions)\?(threadUrn=(urn*.+)|(action=updateReaction)|(action=deleteReaction))/
str = 'https://www.linkedin.com/voyager/api/voyagerSocialDashReactions?threadUrn=urn:li:activity:7033962785659105280'
# Print the match result
str.match(re) do |match|
puts match.to_s
end