const regex = /https?:\/\/www?\.?linkedin\.com(\/voyager\/api\/voyagerSocialDashReactions)\?(threadUrn=(urn*.+)|(action=updateReaction)|(action=deleteReaction))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https?:\\\/\\\/www?\\.?linkedin\\.com(\\\/voyager\\\/api\\\/voyagerSocialDashReactions)\\?(threadUrn=(urn*.+)|(action=updateReaction)|(action=deleteReaction))', '')
const str = `https://www.linkedin.com/voyager/api/voyagerSocialDashReactions?threadUrn=urn:li:activity:7033962785659105280`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}