import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?:\\/\\/www?\\.?linkedin\\.com(\\/voyager\\/api\\/voyagerSocialDashReactions)\\?(threadUrn=(urn*.+)|(action=updateReaction)|(action=deleteReaction))";
final String string = "https://www.linkedin.com/voyager/api/voyagerSocialDashReactions?threadUrn=urn:li:activity:7033962785659105280";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}