$re = '/https?:\/\/www?\.?linkedin\.com(\/voyager\/api\/voyagerSocialDashReactions)\?(threadUrn=(urn*.+)|(action=updateReaction)|(action=deleteReaction))/';
$str = 'https://www.linkedin.com/voyager/api/voyagerSocialDashReactions?threadUrn=urn:li:activity:7033962785659105280';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);