#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?<Function_Call>\w+\s*\([^()]*\))|(?<NC_Address>[a-z]+\s*[+-]?[0-9]*[.]?[0-9]+)"
Local $sString = "G1" & @CRLF & _
"" & @CRLF & _
"ang 17.3" & @CRLF & _
"" & @CRLF & _
"func ()" & @CRLF & _
"" & @CRLF & _
"foo(,,7,z)" & @CRLF & _
"" & @CRLF & _
"func1 () or func2A(a, x, 5.2)" & @CRLF & _
"G1X0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")