using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<Function_Call>\w+\s*\([^()]*\))|(?<NC_Address>[a-z]+\s*[+-]?[0-9]*[.]?[0-9]+)";
string input = @"G1
ang 17.3
func ()
foo(,,7,z)
func1 () or func2A(a, x, 5.2)
G1X0";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}