const regex = new RegExp('(?<Function_Call>\\w+\\s*\\([^()]*\\))|(?<NC_Address>[a-z]+\\s*[+-]?[0-9]*[.]?[0-9]+)', 'gmi')
const str = `G1
ang 17.3
func ()
foo(,,7,z)
func1 () or func2A(a, x, 5.2)
G1X0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}