re = /(?<Function_Call>\w+\s*\([^()]*\))|(?<NC_Address>[a-z]+\s*[+-]?[0-9]*[.]?[0-9]+)/mi
str = 'G1
ang 17.3
func ()
foo(,,7,z)
func1 () or func2A(a, x, 5.2)
G1X0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end