package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(?<Function_Call>\w+\s*\([^()]*\))|(?<NC_Address>[a-z]+\s*[+-]?[0-9]*[.]?[0-9]+)`)
var str = `G1
ang 17.3
func ()
foo(,,7,z)
func1 () or func2A(a, x, 5.2)
G1X0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}