use strict;
my $str = 'aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
sdaffdsdfsdsfaadd
afdsafdsfssdsfdfs
afdsfdssdfdssfdsf
asfddsfafsdfdsdsf
asfdsdfafdsafasdf
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
';
my $regex = qr/(?:^(?=(?:.+\R){4,}.+(?:\R^$|\Z)).{4}\K.{2} | \G(?=(?:.+\R){4,}.+(?:\R^$|\Z)).+\K.{2}(?=.{4}$))
| ^(?=(?:.+\R){3}.+(?:\R^$|\Z)).{2} | \G(?=(?:.+\R){3}.+(?:\R^$|\Z)).+\K.{2}(?=$)
| ^(?=(?:.+\R){2}.+(?:\R^$|\Z)).\K.{2} | \G(?=(?:.+\R){2}.+(?:\R^$|\Z)).+\K.{2}(?=.$)
| ^(?=(?:.+\R).+(?:\R^$|\Z)).{2}\K.{2} | \G(?=(?:.+\R).+(?:\R^$|\Z)).+\K.{2}(?=.{2}$)
| ^(?=(?:.+(?:\R^$|\Z))).{3}\K.+(?=.{3}(?:\R^$|\Z))/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}