import Foundation
let pattern = #"""
(?:^(?=(?:.+\R){4,}.+(?:\R^$|\Z)).{4}\K.{2} | \G(?=(?:.+\R){4,}.+(?:\R^$|\Z)).+\K.{2}(?=.{4}$))
| ^(?=(?:.+\R){3}.+(?:\R^$|\Z)).{2} | \G(?=(?:.+\R){3}.+(?:\R^$|\Z)).+\K.{2}(?=$)
| ^(?=(?:.+\R){2}.+(?:\R^$|\Z)).\K.{2} | \G(?=(?:.+\R){2}.+(?:\R^$|\Z)).+\K.{2}(?=.$)
| ^(?=(?:.+\R).+(?:\R^$|\Z)).{2}\K.{2} | \G(?=(?:.+\R).+(?:\R^$|\Z)).+\K.{2}(?=.{2}$)
| ^(?=(?:.+(?:\R^$|\Z))).{3}\K.+(?=.{3}(?:\R^$|\Z))
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
sdaffdsdfsdsfaadd
afdsafdsfssdsfdfs
afdsfdssdfdssfdsf
asfddsfafsdfdsdsf
asfdsdfafdsafasdf
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)