$re = '/(?:^(?=(?:.+\R){4,}.+(?:\R^$|\Z)).{4}\K.{2} | \G(?=(?:.+\R){4,}.+(?:\R^$|\Z)).+\K.{2}(?=.{4}$))
| ^(?=(?:.+\R){3}.+(?:\R^$|\Z)).{2} | \G(?=(?:.+\R){3}.+(?:\R^$|\Z)).+\K.{2}(?=$)
| ^(?=(?:.+\R){2}.+(?:\R^$|\Z)).\K.{2} | \G(?=(?:.+\R){2}.+(?:\R^$|\Z)).+\K.{2}(?=.$)
| ^(?=(?:.+\R).+(?:\R^$|\Z)).{2}\K.{2} | \G(?=(?:.+\R).+(?:\R^$|\Z)).+\K.{2}(?=.{2}$)
| ^(?=(?:.+(?:\R^$|\Z))).{3}\K.+(?=.{3}(?:\R^$|\Z))/mx';
$str = 'aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
sdaffdsdfsdsfaadd
afdsafdsfssdsfdfs
afdsfdssdfdssfdsf
asfddsfafsdfdsdsf
asfdsdfafdsafasdf
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);