#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\s*(?<days>\d+)\s*days*)?(?:\s*(?<hours>\d+)\s*hours*)?(?:\s*(?<minutes>\d+)\s*minutes*)?"
Local $sString = "1 day 15hours 08 minutes" & @CRLF & _
"1days 15 hour" & @CRLF & _
"15 hours 08minute" & @CRLF & _
"1 days 08 minutes" & @CRLF & _
"08minutes" & @CRLF & _
"15 hours" & @CRLF & _
"1 day"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")