import re
regex = re.compile(r"(?:\s*(?<days>\d+)\s*days*)?(?:\s*(?<hours>\d+)\s*hours*)?(?:\s*(?<minutes>\d+)\s*minutes*)?", flags=re.MULTILINE)
test_str = ("1 day 15hours 08 minutes\n"
"1days 15 hour\n"
"15 hours 08minute\n"
"1 days 08 minutes\n"
"08minutes\n"
"15 hours\n"
"1 day")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")