re = /(?:\s*(?<days>\d+)\s*days*)?(?:\s*(?<hours>\d+)\s*hours*)?(?:\s*(?<minutes>\d+)\s*minutes*)?/m
str = '1 day 15hours 08 minutes
1days 15 hour
15 hours 08minute
1 days 08 minutes
08minutes
15 hours
1 day'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end