import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\s*(?<days>\\d+)\\s*days*)?(?:\\s*(?<hours>\\d+)\\s*hours*)?(?:\\s*(?<minutes>\\d+)\\s*minutes*)?";
final String string = "1 day 15hours 08 minutes\n"
+ "1days 15 hour\n"
+ "15 hours 08minute\n"
+ "1 days 08 minutes\n"
+ "08minutes\n"
+ "15 hours\n"
+ "1 day";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}