package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\s*(?<days>\d+)\s*days*)?(?:\s*(?<hours>\d+)\s*hours*)?(?:\s*(?<minutes>\d+)\s*minutes*)?`)
var str = `1 day 15hours 08 minutes
1days 15 hour
15 hours 08minute
1 days 08 minutes
08minutes
15 hours
1 day`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}