using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(([^)]+)\)";
string substitution = @"pippo";
string input = @"(hello)";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}