use strict;
my $str = '(hello)';
my $regex = qr/\(([^)]+)\)/p;
my $subst = 'pippo';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";