#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+\s+(?<code>(20[012])).*(action:(?<!read))?"
Local $sString = "1 200 file:test01.txt, action:read, User:dummy" & @CRLF & _
"2 201 file:test01.txt, action:write, User:dummy" & @CRLF & _
"3 202 file:unknown, keepalive , User:dummy" & @CRLF & _
"4 450 file:test01.txt, action:read, User:dummy" & @CRLF & _
"5 500 file:test01.txt, action:read, User:dummy" & @CRLF & _
"6 201 profiles, action:reload, User:dummy"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")