re = /^\d+\s+(?<code>(20[012])).*(action:(?<!read))?/m
str = '1 200 file:test01.txt, action:read, User:dummy
2 201 file:test01.txt, action:write, User:dummy
3 202 file:unknown, keepalive , User:dummy
4 450 file:test01.txt, action:read, User:dummy
5 500 file:test01.txt, action:read, User:dummy
6 201 profiles, action:reload, User:dummy'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end