import re
regex = re.compile(r"^\d+\s+(?<code>(20[012])).*(action:(?<!read))?", flags=re.MULTILINE)
test_str = ("1 200 file:test01.txt, action:read, User:dummy\n"
"2 201 file:test01.txt, action:write, User:dummy\n"
"3 202 file:unknown, keepalive , User:dummy\n"
"4 450 file:test01.txt, action:read, User:dummy\n"
"5 500 file:test01.txt, action:read, User:dummy\n"
"6 201 profiles, action:reload, User:dummy")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")