#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^[A-Za-z ]+(?:-[A-Za-z]{0,3})?$"
Local $sString = "A" & @CRLF & _
"An" & @CRLF & _
"Any" & @CRLF & _
"Any " & @CRLF & _
"Any w" & @CRLF & _
"Any wo" & @CRLF & _
"Any wor" & @CRLF & _
"Any word" & @CRLF & _
"Any words" & @CRLF & _
"Any words -" & @CRLF & _
"Any words -A" & @CRLF & _
"Any words -AJ" & @CRLF & _
"Any words -AJW" & @CRLF & _
"Any words -AJWa" & @CRLF & _
"Any words -AJWab" & @CRLF & _
"Any words -AJWabc" & @CRLF & _
"-" & @CRLF & _
"-A" & @CRLF & _
"-AJ" & @CRLF & _
"-AJW" & @CRLF & _
"-AJW-" & @CRLF & _
"-AJW-A" & @CRLF & _
"-AJW-AJ" & @CRLF & _
"-AJW-AJW" & @CRLF & _
"And not Anywords-anywords-AJW" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")