import re
regex = re.compile(r"""
^[A-Za-z ]+(?:-[A-Za-z]{0,3})?$
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("A\n"
"An\n"
"Any\n"
"Any \n"
"Any w\n"
"Any wo\n"
"Any wor\n"
"Any word\n"
"Any words\n"
"Any words -\n"
"Any words -A\n"
"Any words -AJ\n"
"Any words -AJW\n"
"Any words -AJWa\n"
"Any words -AJWab\n"
"Any words -AJWabc\n"
"-\n"
"-A\n"
"-AJ\n"
"-AJW\n"
"-AJW-\n"
"-AJW-A\n"
"-AJW-AJ\n"
"-AJW-AJW\n"
"And not Anywords-anywords-AJW\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")