use strict;
my $str = 'A
An
Any
Any
Any w
Any wo
Any wor
Any word
Any words
Any words -
Any words -A
Any words -AJ
Any words -AJW
Any words -AJWa
Any words -AJWab
Any words -AJWabc
-
-A
-AJ
-AJW
-AJW-
-AJW-A
-AJW-AJ
-AJW-AJW
And not Anywords-anywords-AJW
';
my $regex = qr/^[A-Za-z ]+(?:-[A-Za-z]{0,3})?$/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}