import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Za-z ]+(?:-[A-Za-z]{0,3})?$";
final String string = "A\n"
+ "An\n"
+ "Any\n"
+ "Any \n"
+ "Any w\n"
+ "Any wo\n"
+ "Any wor\n"
+ "Any word\n"
+ "Any words\n"
+ "Any words -\n"
+ "Any words -A\n"
+ "Any words -AJ\n"
+ "Any words -AJW\n"
+ "Any words -AJWa\n"
+ "Any words -AJWab\n"
+ "Any words -AJWabc\n"
+ "-\n"
+ "-A\n"
+ "-AJ\n"
+ "-AJW\n"
+ "-AJW-\n"
+ "-AJW-A\n"
+ "-AJW-AJ\n"
+ "-AJW-AJW\n"
+ "And not Anywords-anywords-AJW\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}